最新消息:

KLOXO升级最新版本网站500错误的解决办法

教程 站长 223浏览 0评论

由于KLOXO是linux为数不多的免费主机面板,所以相当多的朋友选择在VPS上安装此面板方便管理自己的网站,赵容也在博客中做过一系列的安装和使用教程。最近,有不少朋友升级最新版本后反应一些问题,主要表现为网站无法打开了,在KLOXO后台使用apache的显示500,使用lighttpd的显示空白页。

kloxo-500

出现上面的问题,是由KLOXO升级引起的问题,原因在于PHP5.2.17-13加入了对php-fpm的支持,升级后无法像之前版本那样直接调用php-cgi文件。下面,我们提供修复此问题方法。

登陆进kloxo,进入命令控制台,在输入框执行

yum downgrade php php-cli php-common php-devel php-gd php-imap php-mbstring php-mcrypt php-mysql php-pdo php-xml –y

执行命令后,在下面的大输入框会出现以下内容:

Loaded plugins: fastestmirror, protectbase
Repository ‘vz-base’ is missing name in configuration, using id
Repository ‘vz-updates’ is missing name in configuration, using id
Setting up Downgrade Process
Loading mirror speeds from cached hostfile
* base: mirrors.kernel.org
* extras: mirrors.kernel.org
* updates: mirrors.kernel.org
0 packages excluded due to repository protections
Only Upgrade available on package: php-mcrypt-5.1.6-15.el5.centos.1.i386
Resolving Dependencies
–> Running transaction check
—> Package php.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-cli.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-cli.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-common.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-common.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-devel.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-devel.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-gd.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-gd.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-imap.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-imap.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-mbstring.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-mbstring.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-mysql.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-mysql.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-pdo.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-pdo.i386 0:5.1.6-27.el5_7.4 set to be erased
—> Package php-xml.i386 0:5.1.6-27.el5_5.3 set to be updated
—> Package php-xml.i386 0:5.1.6-27.el5_7.4 set to be erased
–> Finished Dependency Resolution
Dependencies Resolved
================================================================================
Package              Arch         Version                   Repository    Size
================================================================================
Downgrading:
php                  i386         5.1.6-27.el5_5.3          base         2.3 M
php-cli              i386         5.1.6-27.el5_5.3          base         2.1 M
php-common           i386         5.1.6-27.el5_5.3          base         153 k
php-devel            i386         5.1.6-27.el5_5.3          base         503 k
php-gd               i386         5.1.6-27.el5_5.3          base         117 k
php-imap             i386         5.1.6-27.el5_5.3          base          54 k
php-mbstring         i386         5.1.6-27.el5_5.3          base         995 k
php-mysql            i386         5.1.6-27.el5_5.3          base          86 k
php-pdo              i386         5.1.6-27.el5_5.3          base          65 k
php-xml              i386         5.1.6-27.el5_5.3          base          97 k
Transaction Summary
================================================================================
Remove        0 Package(s)
Reinstall     0 Package(s)
Downgrade    10 Package(s)
Total download size: 6.4 M
Downloading Packages:
——————————————————————————–
Total                                           6.7 MB/s | 6.4 MB     00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing     : php-common                                              1/20
Installing     : php-pdo                                                 2/20
Installing     : php-cli                                                 3/20
Installing     : php                                                     4/20
Installing     : php-devel                                               5/20
Installing     : php-mbstring                                            6/20
Installing     : php-gd                                                  7/20
Installing     : php-mysql                                               8/20
Installing     : php-imap                                                9/20
Installing     : php-xml                                                10/20
Cleanup        : php-xml                                                11/20
Cleanup        : php-devel                                              12/20
Cleanup        : php-cli                                                13/20
Cleanup        : php-mbstring                                           14/20
Cleanup        : php-gd                                                 15/20
Cleanup        : php-common                                             16/20
Cleanup        : php                                                    17/20
Cleanup        : php-mysql                                              18/20
Cleanup        : php-pdo                                                19/20
Cleanup        : php-imap                                               20/20
Removed:
php.i386 0:5.1.6-27.el5_7.4              php-cli.i386 0:5.1.6-27.el5_7.4
php-common.i386 0:5.1.6-27.el5_7.4       php-devel.i386 0:5.1.6-27.el5_7.4
php-gd.i386 0:5.1.6-27.el5_7.4           php-imap.i386 0:5.1.6-27.el5_7.4
php-mbstring.i386 0:5.1.6-27.el5_7.4     php-mysql.i386 0:5.1.6-27.el5_7.4
php-pdo.i386 0:5.1.6-27.el5_7.4          php-xml.i386 0:5.1.6-27.el5_7.4
Installed:
php.i386 0:5.1.6-27.el5_5.3              php-cli.i386 0:5.1.6-27.el5_5.3
php-common.i386 0:5.1.6-27.el5_5.3       php-devel.i386 0:5.1.6-27.el5_5.3
php-gd.i386 0:5.1.6-27.el5_5.3           php-imap.i386 0:5.1.6-27.el5_5.3
php-mbstring.i386 0:5.1.6-27.el5_5.3     php-mysql.i386 0:5.1.6-27.el5_5.3
php-pdo.i386 0:5.1.6-27.el5_5.3          php-xml.i386 0:5.1.6-27.el5_5.3
Complete!

当您看到Complete就表明修复成功了,最好重启下VPS。

另外,由于不少的朋友反映最新版的KLOXO存在各种不适应的状况,所以,赵容建议您勿盲目升级,并在KLOXO后台设定关闭自动更新。

转载请注明:3号VPS » KLOXO升级最新版本网站500错误的解决办法

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址