最新消息:

LNMP0.8安装ionCube和eAccelerator后显示“不支持”的解决方法

教程 站长 133浏览 0评论

买了VPS之后,赵容喜欢装个军哥的lnmp,即使是闲置,无聊时看看探针也方便。相信很多朋友也在使用这个一键包,比较简单,复制、粘贴,然后就是waiting……不过,昨天有朋友反映,使用最新的lnmp.8,装好ionCube和eAccelerator后,探针依然显示不支持”,赵容看了下,确实如此,不过,解决的方式不算麻烦,这里分享给大家。

首先,按照教程装完lnmp0.8,然后在lnmp0.8目录下运行./ionCube.sh和./eaccelerator.sh回车安装这两个组件,完成后查看探针,确实显示不支持。奇怪了,我刚明明按照军哥的教程安装的,为什么他会显示不支持呢?管它的,先重启下lnmp看看!

/root/lnmp restart

提示如图:

lnmp0411

有报错,看来有问题!提示貌似是选择相关组件的路径不对?是的,不被支持,是由于相关组件路径问题,PHP5.2.17使用的是ioncube_loader_lin_5.2.so不是5.3,而eaccelerator路径是no-debug-non-zts-20060613 而不是no-debug-non-zts-20090626,明白了原因,修改就简单了。

下载php.ini到本地,或者直接vi /usr/local/php/etc/php.ini修改:

zend_extension=”/usr/local/ioncube/ioncube_loader_lin_5.3.so”

修改为  zend_extension=”/usr/local/ioncube/ioncube_loader_lin_5.2.so”

zend_extension=”/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/eaccelerator.so”

修改为 zend_extension=”/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/eaccelerator.so”

然后刷新探针,呕耶!终于显示支持咯!希望军哥会修正脚本的这个问题,那时就不用这么麻烦了!

转载请注明:3号VPS » LNMP0.8安装ionCube和eAccelerator后显示“不支持”的解决方法

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址